logo头像

小玉的技术博客

flutter入门之在macOS上搭建开发环境

系统要求

要安装并运行Flutter,您的开发环境必须满足以下最低要求:

  • 操作系统: macOS (64-bit)
  • 磁盘空间: 700 MB (不包括Xcode或Android Studio的磁盘空间).
  • 工具: Flutter 依赖下面这些命令行工具.
    bash, mkdir, rm, git, curl, unzip, which

    获取flutter SDK

    1.去flutter官网下载其最新可用的安装包,转到下载页
    注意,Flutter的渠道版本会不停变动,请以Flutter官网为准。另外,在中国大陆地区,要想正常获取安装包列表或下载安装包,可能需要翻墙,读者也可以去Flutter github项目下去下载安装包,转到下载页

2.解压安装包到你想安装的目录,比如我是放在用户目录下面

3.添加flutter相关工具到path中:

1
export PATH=`pwd`/flutter/bin:$PATH

运行 flutter doctor

运行以下命令查看是否需要安装其它依赖项来完成安装:

1
flutter doctor


该命令检查您的环境并在终端窗口中显示报告。Dart SDK已经在捆绑在Flutter里了,没有必要单独安装Dart。 仔细检查命令行输出以获取可能需要安装的其他软件或进一步需要执行的任务(以粗体显示)

第一次运行一个flutter命令(如flutter doctor)时,它会下载它自己的依赖项并自行编译。以后再运行就会快得多。

以下各部分介绍如何执行这些任务并完成设置过程。你会看到在flutter doctor输出中, 如果你选择使用IDE,我们提供了,IntelliJ IDEA,Android Studio和VS Code的插件, 请参阅编辑器设置 以了解安装Flutter和Dart插件的步骤。

一旦你安装了任何缺失的依赖,再次运行flutter doctor命令来验证你是否已经正确地设置了。

支付宝打赏 微信打赏

赞赏是不耍流氓的鼓励